The £800 microswitch… and some other things.

OK, so fixing the other projector (an Epson EMP-50) was a little bit trickier than the first one.

Problem: It didn’t power up. No lights. Nothing. Nada. OK, I figured that was a power supply issue. Stripped it down to it’s component parts (left the optical engine and ballast), spotted the bad connection- this projector had been damaged by being dropped, and the whole frame had warped a bit. This connection, between the IEC connector on the side for power and the horizontal power supply board, had fallen out entirely. Reconnected and resoldered, and subsequently reassembled- and I get a ‘circuit error’ when trying to power up.

So, back to the disassembly. Took out the ballast unit on a hunch and spotted a microswitch which a service manual claims detects when the lamp housing is open. Unfortunately, this doesn’t work too well when the frame’s a bit bent, so I soldered over that on the mainboard. Reassembled, again.

Getting a little bored with the constant dis/reassembly at this point- and it still doesn’t start. Bulb struck, which was a great morale booster, but it then shut down and burned it’s fans at maximum for 5 minutes before turning off. Not too useful.

Poked around a bit and considered these symptoms were similar to what my other projector had- lo and behold, the fan on the smoothing unit is jammed! One of the support struts for the fan was snapped, and a quick spot of superglue fixed that in place and let it spin freely again. Reassembled, and bam! Working projector #2. I’ll post pics sometime.

All in all that’s two projectors for £0 which I’ve gotten working again with long remaining bulb lifes in each. Total resources required: Three screwdrivers, a Torx driver, three forceps (Seriously- best tool I’ve ever had for electronics work), some narrownose pliers, antistatic gloves and static control kit (to avoid frying the mainboard), soldering iron (Got a new Weller temperature controlled iron, which is doing great), approximately 4mm of solder, a dab of Loctite superglue, an IEC power lead and some spare time. Oh, and lots of caffeine.

If I get a chance tomorrow I’ll see about throwing a post up about some of the under-the-hood changes I’ve been making and have planned for EVE Metrics and other sites. I’m looking more seriously at a single-sign-on solution between all the MMMetrics sites (ISKsense, EM, AccVIEW)- but the question is, if I do a SSO solution why not make that a global SSO solution with OpenID support for pluging in other sites? More to the point, allowing centralised API key management between applications that need it (EVE Metrics would use this to store/retrieve keys) would be great- give application your MMMetrics ID, MMMetrics prompts you to give access to your account data to that site, optionally letting you provide one or more API keys to the site. Kinda like a badass Gatecamper 2 that doesn’t suck so badly. Thoughts?